Surround Sound Processors and Pre / Pros (General Discussion)

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Sonos Connect not working on XMC-1
batu 7 137 by donh50
Dec 13, 2019 18:38:12 GMT -5
Thread  
newBookmarkLockedFalling UMC-1 won’t play “All Stereo” mode
tsantil 6 107 by geebo
Dec 7, 2019 0:43:49 GMT -5
Thread  
newBookmarkLockedFalling Can't perform update to XMC-2
wilyearthworm 3 268 by Lsc
Dec 5, 2019 7:45:48 GMT -5
Thread  
newBookmarkLockedFalling Til emotiva skriv til mig !!
henrikrace 3 201 by AudioHTIT
Nov 20, 2019 11:04:18 GMT -5
Thread  
newBookmarkLockedFalling Best Processor for 9.4.6 Home Theater
Pages:
cwmcobra 22 1,273 by davidl81
Nov 13, 2019 17:14:13 GMT -5
Thread  
newBookmarkLockedFalling XMC-2 & Atmos - Which surround channels?
Priapulus 13 775 by Gary Cook
Oct 13, 2019 14:09:58 GMT -5
Thread  
newBookmarkLockedFalling XMC-2 vs. RMC-1
jonathan 3 2,390 by repeetavx
Aug 17, 2019 14:53:14 GMT -5
Thread  
newBookmarkLockedFalling UMC-1 dead, is it worth fixing?
blinn 3 408 by AudioHTIT
Aug 7, 2019 17:34:25 GMT -5
Thread  
newBookmarkLockedFalling UMC 200 Manual PDF
unsound 4 985 by unsound
Jun 9, 2019 7:38:43 GMT -5
Thread  
newBookmarkLockedFalling No audio from my MC700
journeywego 3 440 by cyyyr05
Apr 28, 2019 3:52:04 GMT -5
Thread  
newBookmarkLockedFalling Problem with lip sync
acousticmood 7 725 by doc1963
Apr 22, 2019 3:16:17 GMT -5
Thread  
newBookmarkLockedFalling Navigation Locked Out
springwright 4 234 by klinemj
Jan 3, 2019 22:08:45 GMT -5
Thread  
newBookmarkLockedFalling Upgrade possible?
sophie999 3 444 by bootman
Jan 1, 2019 14:07:17 GMT -5
Thread  
newBookmarkLockedFalling XMC-1 Atmos & DTS-X Update Anticipation thread
Pages:
sahmen 92 7,801 by dimora
Dec 9, 2018 22:33:01 GMT -5
Thread  
newBookmarkLockedFalling UMC 200 dual subs
rdlkgliders 1 278 by Gary Cook
Dec 1, 2018 14:55:46 GMT -5
Thread  
newBookmarkLockedFalling UMC-200 Handshake issues.
maseline97 17 859 by rcs
Nov 19, 2018 12:00:09 GMT -5
Thread  
newBookmarkLockedFalling Mc 700 and oppo 105 problems
frisco 4 391 by cwt
Oct 8, 2018 7:23:59 GMT -5
Thread  
newBookmarkLockedFalling Can't get 60fps at 4k with v3 XMC-1
brockjon 2 545 by brockjon
Aug 26, 2018 0:53:13 GMT -5
Thread  
newBookmarkLockedFalling No Speakers Detected in EMQ
dbesh2 3 334 by dbesh2
Aug 15, 2018 8:57:15 GMT -5
Thread  
newBookmarkLockedFalling MC-700 question regarding replacing my pre 4k Integra AVR
jrd5853 6 873 by romanski
Jul 31, 2018 10:31:59 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Statistics
Threads and Posts
Total Threads:125
Total Posts:1,461
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.